SMsoft – informatica e dintorni

$_REQUEST[‘PHPSESSID’] e PHP 5.3

Usando PHP 5.3 avrete sicuramente notato che la variabile globale $_REQUEST[‘PHPSESSID’] non è più valorizzata. Si tratta di un’impostazione di sicurezza di questa versione di PHP.

Se proprio non potete fare a meno di utilizzare tale variabile, se ne può riattivare il funzionamento, modificando il file di configurazione di php (solitamente /etc/php5/php.ini) ed in particolare la direttiva request_order che deve diventare:

In questo modo verranno nuovamente inserite nell’array globale $_REQUEST anche gli elementi dell’array globale $_COOKIE e $_SERVER.

Ovviamente va poi riavviato apache:

enjoy!




Se hai trovato utili le informazioni su questo blog,
Fai una donazione!
Clicca sul bottone qui sotto o almeno clicca sul banner pubblicitario :-)
*

Commenti

Page optimized by WP Minify WordPress Plugin